Zookeeper安装

1、首先去官网下载了最新版本:zookeeper-3.5.6。

2、我用的debian系统,修改配置文件。

3、然后启动,报错了:

错误: 找不到或无法加载主类org.apache.zookeeper.server.quorum.QuorumPeerMain

1.png

解决方案

总结:

原来从目前的最新版本3.5.5开始,带有bin名称的包才是我们想要的下载可以直接使用的里面有编译后的二进制的包,而之前的普通的tar.gz的包里面是只是源码的包无法直接使用。

3.png

重新下载后解压,修改配置文件!启动成功

2.jpg

参考:https://blog.csdn.net/jiangxiulilinux/article/details/96433560

最后修改:2020 年 02 月 05 日 01 : 21 PM
如果觉得我的文章对你有用,请随意赞赏